Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-01-2019, 11:06 AM   #1
Senior Member
 
twinster2's Avatar
 
Join Date: Apr 2016
Location: Kalamazoo, MI & Leesburg, FL
Posts: 514
Default Roof issue.

Roof issues finally caught me. While on my roof cleaning and UV treating it, I noticed an area near the front left where the decking detached at a seam. The TTP roofing is still intact and the decking itself is solid and no leaks were found. Probably just happened within the last month, since I didn't notce when I was on the roof last month installing a fan. Not sure what to do other than monitor the issue for now.
__________________

twinster2 is offline   Reply With Quote
Old 08-11-2019, 01:14 PM   #2
Junior Member
 
Join Date: Sep 2016
Posts: 1
Default

That happens to us also..
The dealer said it was a manufacturing defect and fixed it at no cost.
__________________

smokepole is offline   Reply With Quote
Old 08-11-2019, 03:23 PM   #3
Junior Member
 
Join Date: Jun 2014
Location: Virginia
Posts: 3
Default

Same thing happened to my FF 265 near end of warranty. Fixed by dealer at no cost.
JefPal is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:42 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2019, vBulletin Solutions, Inc.