Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-01-2009, 09:11 AM   #1
Junior Member
 
Join Date: Jun 2009
Posts: 10
Default AC and Other Issues with X210

Once again I am back with another annoying issue with my new X210. When I bought the trailer I immediately discovered the AC breaker would trip in the main panel at start up. Sometimes two or three times a day or on some days not at all. I took it back to the dealer who claimed to have found a lose wire. Took it on vacation and it kicked once in a one week period in hot weather. Back to the beach and it kicked twice in one weekend. Over to the mountains two weeks ago and it tripped during the night at start up. Back to the dealer where it has been for a week and they can't get it to trip. Can't leave my dog in the trailer even for a short time the way it is now just to grab some dinner. Annoying. Has anyone else had similar problems?

Oh yell, gave up on them ever fixing the electric stabilizer jacks so I took the motors off. Best thing I ever did to the trailer. Now I know what I got when I get to the campground. Don't know why they would even install motors on short jacks anyway.

Junker TV will be gone before next season.

With all that said I had a really great summer in the trailer. Really got to figure out the AC issue thou.
210GUY is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 02:01 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.