Thread Tools Search this Thread Display Modes
Old 04-09-2013, 02:31 PM   #1
Junior Member
Join Date: Apr 2013
Posts: 1
Default Question about the Suburban LP furnace in my Fun Finder 189

I have just bought a used 2006 Fun Finder X 189FD. It is in great condition and we are very excited and looking forward to taking it out for the first time. In trying to familiarize my self with all the amenities, I've not been able to get the furnace to light. I've followed the instructions in the owners manual but no luck. When I turn the thermostat on I hear a click but nothing more happens.
This is our first travel trailer, so I'm not really familiar with the workings. Any help will be greatly appreciately!
L & S

hls1252 is offline   Reply With Quote
Old 04-10-2013, 06:58 AM   #2
Site Team
Join Date: Oct 2009
Location: Arizona
Posts: 965

Sometimes it can take a while for the propane to get from the tank to the furnace. Check to see if there is gas at the stove by lighting a burner. If not leave the burner on and continue trying to light it. Once it lights try the heater again.
2011 Chevy Silverado Crew Cab 4X4
2009 210 WBS
Prodigy P3
LJAZ is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 06:22 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2018, vBulletin Solutions, Inc.