Reply
 
Thread Tools Search this Thread Display Modes
 
Old 07-16-2008, 03:25 PM   #1
Junior Member
 
Join Date: Jul 2008
Posts: 1
Send a message via Yahoo to kennro
Default x240 - Newbs

We have ordered a new 2007 x240 from a dealership that had it in overstock from last year. It hasn't arrived yet, but should any day now. Has this not been a very popular model? We noticed they have discontinued it for 2009.

If anyone owns an '07 x240, maybe you could give us some hints on what to look for in terms of trouble spots. We'd also like to hear about your experiences and possible recommendations for upgrades.

We're very excited, a little nervous, and ready to share family entertainment with our 7-year old that DOESN'T center around a television or computer.

First time posters; long time readers.

The K's
__________________

kennro is offline   Reply With Quote
Old 07-28-2008, 07:02 AM   #2
Senior Member
 
Join Date: Mar 2008
Location: Phoenix, Arizona
Posts: 173
Default

Hey K's!! We have had no real problems so far, just regular new trailer stuff. (loose trim, etc!) Good Luck!
__________________

__________________
Alan
2006 Nissan Xterra
B&M Trans Cooler
Equalizer Hitch
2011 Nomad 206
Panasonic/Pioneer/Kicker ~ Audio/Video System
Days Camped /2009 / 33
keyser soze is offline   Reply With Quote
Old 08-08-2008, 03:20 PM   #3
Junior Member
 
Join Date: Aug 2008
Posts: 1
Default 2008 FF

All I can say about our FF is that I wish I would have used a fine toothed comb to inspect when we picked it up.

I should have had a clue that things were not looking good when we had a water leak in the beginning. A small affair that we discovered after the first trip. It wasn't in the supply lines either. It was a gray water leak in the pipe from the kitchen to the tank. It shouldn't even have happened due to the nature of waste lines. They are gravity fed and even if not sealed properly, the water should just drain away. BUT WAIT... there's more! Upon CLOSE inspection, I realized that the sink line ran UP to the main drain line, causing gray waste to sit in the joint that was NOT sealed/glued properly and the pin hole leak there was caused a drip. Though promptly fixed by the dealer, it was a bad omen.

I am in the process of writing a letter to FF now to address a whole list of problems that would be ok if it were only 1 or 2, but I have a whole list of workmanship issues that I am addressing. So much so that I hope they decide to replace the unit. Not likely, but I will extol their virtues if they do, and poo poo all over them if they don't.

Good luck with yours, but I feel like we got "the one" that is a lemon.
tobinak is offline   Reply With Quote
Old 08-10-2008, 06:08 PM   #4
Member
 
Join Date: Jul 2008
Location: Lake Winola,PA
Posts: 80
Default

what othe rkind of problems did you have
__________________
08 FunFinderX 160
07 Wrangler Rubicon
JeepGuy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3

All times are GMT -6. The time now is 11:43 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2017, vBulletin Solutions, Inc.