Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-05-2012, 04:05 AM   #1
roy
Senior Member
 
Join Date: Feb 2012
Location: Mississippi
Posts: 303
Default AC BREAKER KEEPS FLIPPING OFF

We are one night camping in goodlett tx temp when we rolled in was 108 outside. AC ran for about an hour the the breaker started tripping. It did this four times. Took 5 hours to get the camper cooled off. We've never been in heat like this. Breakers were hot to the touch until it started cycling in the wee hours of the morning. I'm Leary of this camper we keep having electrical problems. I know it was hot extremely hot but should it have been heating up the breakers to trip them? This thing has so many problems I almost can't wait to take it back in nov our first chance to get it looked at.

Others in campground reported their AC's struggling but no breaker trips.

Advise? We leave this oven today and should be in Durango, CO by night fall much cooler there I hope.
__________________

__________________
2012 Fun finder Xtra XT-276, Pitbull strapless restraints
2016 GMC Sierra Denali HD Duramax/Allison 4wd

WERA Expert #826
roy is offline   Reply With Quote
Old 08-05-2012, 10:16 AM   #2
Site Team
 
Join Date: Oct 2009
Location: Arizona
Posts: 1,249
Default

It's also possible that the campground power pedestal you were hooked to had a problem. It's not that uncommon. With the high temperature surely everyone was running their AC which could really put quite a load on the CG's 'grid'.
__________________

__________________
2011 Chevy Silverado Crew Cab 4X4
2009 210 WBS
Prodigy P3
LJAZ is offline   Reply With Quote
Old 08-08-2012, 06:16 PM   #3
Senior Member
 
Join Date: May 2012
Location: chandler, az
Posts: 197
Send a message via AIM to shadow
Default a/c

we had the same problem, turned out we had a weak breaker, while they claim to require 20a breaker you'll find they all trip before their spec. rating. We are in AZ so we havce been seeing really high temps. I replaced the breaker with 25amp so now it will trip at 20, but it it has not. I ahev monitored amp consumption closely and temps on breakers. This is the new A/C unit and it is sucking the amps running 16-19 which is why it was trippong on the orginal breaker. This past weekend we ran it hard and the unit went south, fan works compressor failed horribly so back for warranty work. I suspect the compressor was an issue from day one as ti woud sometimes make some really odd sounds and really load up in an abnormal way.

my expereince
shadow is offline   Reply With Quote
Old 08-11-2012, 08:31 PM   #4
roy
Senior Member
 
Join Date: Feb 2012
Location: Mississippi
Posts: 303
Default

We have not had any more problems in the Durango, CO campground we have been at this week. Headed to the south rim of the grand canyon tomorrow so the problem could resurface if it's real hot there.
__________________
2012 Fun finder Xtra XT-276, Pitbull strapless restraints
2016 GMC Sierra Denali HD Duramax/Allison 4wd

WERA Expert #826
roy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×