Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-30-2014, 07:30 PM   #1
Member
 
Join Date: Aug 2012
Location: North Carolina
Posts: 91
Default Another trip and of course another new problem

Well last weekend trip I took to go atv riding went well , for 3 days , trailer worked well no problems, so happy , starting to enjoy the trailer some at this point . So here we go to go for a 8 day trip to the beach , check everything over and everything seems great.

Get to the beach and go to plug my iphone in at the outlet at the bottom of the double bed , nothing , so go to the outlet in the front corner where the tv plugs in , sure enough nothing . Thinking ok no big deal breaker tripped, no they are all fine , very long story to short cut , after about a hr of tracing wires under the trailer to the breaker box and figuring out how these guys ran this circuit , I have a cut neutral and part of it is shorted to ground in the ceiling , of course the worst run between the 2 outlets !!! So now I will be working on this thing on my vacation yet again !!!! And I already have people asking me what in the heck are you doing to a brand new trailer !!! So I guess they pinch or ran a screw threw the wire and a little bid of movement and now this , great !!
__________________

__________________
2009 tundra 5.7 double cab
Xt-276 trailer
securityman is offline   Reply With Quote
Old 07-01-2014, 06:26 AM   #2
Senior Member
 
Join Date: Oct 2013
Location: The Mitten State
Posts: 106
Default

You have never tried those outlets until now ??? That was one of the things I made sure worked when we took delivery, just to avoid the situation you had.
__________________

__________________
2014 Fun Finder 214 WSD
Rip5 is offline   Reply With Quote
Old 07-01-2014, 07:21 PM   #3
Member
 
Join Date: Aug 2012
Location: North Carolina
Posts: 91
Default

Rip5 , yes they have been working for the past year and a half , must have been a screw close to the wire or something pinching it and as the box on wheels has been used and pulled behind my truck it must have rubbed on something and shorted it out . But yes everything has been working , this is the 1st electrical problem so far and hope the last .
__________________
2009 tundra 5.7 double cab
Xt-276 trailer
securityman is offline   Reply With Quote
Old 07-14-2014, 09:02 PM   #4
Member
 
Join Date: Aug 2012
Location: North Carolina
Posts: 91
Default

Well just a update , when I got back home I could trouble shoot better and had my meter and tools . Sure enough the neutral wire is broke in the ceiling , try to mess with it , but there was no fishing a wire to fix it threw the ceiling , no big deal reran wire under trailer and connected back the outlets that were not working. Also put my outside outlet on its own circuit so when cooking breakfast , and my wife making coffee inside it wouldn't trip anymore.

But I must say I am happy that I had no leaks whatsoever , it rained so hard and wind was blowing all over for a full day right off the beach , so I am happy about that, see I do say good things when I come across them with this trailer , and for the most part this is what I expected from the rv industry , it's the good times and the memories you have from camping and atv trips!!
Just glad I didn't spend 60,000 - 90,000 on a 5th wheel , I have been looking on other forums and there are all kinds of issues with some of them and very unhappy people .
__________________
2009 tundra 5.7 double cab
Xt-276 trailer
securityman is offline   Reply With Quote
Old 07-15-2014, 05:25 AM   #5
roy
Senior Member
 
Join Date: Feb 2012
Location: Mississippi
Posts: 303
Default

The electrical in these things is total junk. Mine trips breakers all the time and usually I am not over loading anything. It's just wired crazy. Electric tongue jack has been losing power lately. Caught me this last time with jack extended to hook up my hitch bars. All of a sudden no power. Had to break out the 3/4" socket any pull handle and manually let the jack back up. Once home I changed the fuse and sprayed electrical cleaner in the corroded fuse socket and pulled on a wire or two behind the little box door (what a mess that is) and its got power again. It's happened twice so I figure its the fuse holder going bad or loose wire in that junction box mess.

You gotta be able to produce a back up plan at any minute on these things.
__________________
2012 Fun finder Xtra XT-276, Pitbull strapless restraints
2016 GMC Sierra Denali HD Duramax/Allison 4wd

WERA Expert #826
roy is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:51 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×