Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 10-01-2009, 08:14 PM   #1
Junior Member
 
Join Date: Sep 2009
Location: bergen county, NJ
Posts: 8
Default converter?

my TT isn't holding a charge, when plugged in all electrical things work. when plugged into the car all works well. As soon as it is unplugged nothing works. I've checked all the fuses and nothing is blown. I've checked the disconnect nothing seems out of place. Any suggestions would be greatly appreciated. by the way it is a new batter.
__________________

__________________
Ford Explorer 2003
2009 FF 189
2/09
jborchard is offline   Reply With Quote
Old 10-02-2009, 10:25 AM   #2
Member
 
Join Date: Dec 2008
Posts: 79
Default

It sounds like your charger is not working. Do you have a meter? The cheap ones work just as well as the expensive ones. You can usually get them at most hardware stores. Get a digital one, one that is rated to 600V so that you can use it elsewhere.

With you meter on DC. What is your battery voltage? You can measure this right on the battery across the terminals. When you plug in your TT does the charge voltage increase? If you do the same test on you car you can see what the results should be (roughly). If the charge voltage does not go up then either you have a blown fuse or the charger is not working, or your battery still does not work. Some TTs have an inline fuse at the battery check that. If nothing is you kill switch off (if you have one)? Bottom line you will have to follow the wires back and take some measurements to isolate and debug this.

Good luck
Walter
__________________
gator
gator is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 10:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×