Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 08-05-2015, 11:13 AM   #1
Traveling
 
Join Date: Aug 2015
Posts: 2
Default Shower not working

I have a 2011 185 FBS. The shower is connected to the sink faucet. It is enabled by pulling up on the piece in the middle of the faucet. My shower is not working. When I pull up on the piece, water comes out of the shower for few seconds then stops. I can't figure out how to fix this. Any suggestions?
__________________

mgbfitness is offline   Reply With Quote
Old 08-05-2015, 11:32 AM   #2
Senior Member
 
Join Date: Feb 2012
Location: Southern California
Posts: 2,142
Default

That is weird. Was the shower working before this? How long have you had this unit?

What's weird is the idea that it works for a moment and then stops. Usually, if the shower is not working at all, there is a kink in a line (in a newly manufactured unit), or there is a problem with the pump, or there is something wrong with the valve.
__________________

profdant139 is offline   Reply With Quote
Old 08-05-2015, 02:32 PM   #3
Traveling
 
Join Date: Aug 2015
Posts: 2
Default

I have had the unit for 6 months. I have used it numerous times and the shower worked until now. When I pull up on the middle piece the water comes out of the shower for about 10 seconds then it stops. It is very weird. I think it is a problem with the middle piece of the sink where the shower hose connects but I do not know how to fix it. It is connected to the faucet.
mgbfitness is offline   Reply With Quote
Old 08-05-2015, 06:25 PM   #4
Senior Member
 
Join Date: Jan 2012
Location: South Dakota
Posts: 3,106
Default

In my XT276 w/tub/shower and the pull up knob on the tub faucets, the shower worked fine for the first two summers than toward the end of last summer couldn't hardly get any hot water on the hot side in the tub/shower only.

I removed the faucets and found the hot water line was extra long and had kinked between the walls. Apparently it took awhile for the kink to become severe enough to severely reduce hot water flow.

Perhaps the water line(s) kinked behind the faucets ??
__________________
2012 Fun Finder XT 276 Toy Hauler & Harley Davidson Ultra Classic with Condor wheel chock
2014 Dodge Ram 2500 AT 4X4 Crew Cab 6.4 L Hemi, 373 gears, tow package, Rambox option, Revolver X2 tonneau cover, Equal-I-zer anti-sway hitch.
Eagle is offline   Reply With Quote
Old 08-05-2015, 09:19 PM   #5
Senior Member
 
Join Date: May 2011
Location: Southern California
Posts: 206
Default

I have the same unit you have. Don't know if I can help you, but here are the first things I would do if I had the problem. First I would check to make sure that water runs from the sink faucet on both the hot and cold sides without using the shower wand. Then I would hold the shower wand over the sink, turn on either hot or cold or both and then pull up on the hose valve connected to the top of the faucet. I would keep tension in an upward direction. If water did not flow from the shower head wand into the sink, I would then check the on-off buttons on the shower head wand by pushing them in and out while still continuing to hold up on the hose valve. If none of this helps, I would unscrew the hose from the shower wand and see if I have flow and if that did not work, I would unscrew the hose from the top of the hose valve at the faucet. If that was unsuccessful, I would probably take the faucet apart.
__________________
Fun Finder 2006 X189FD sold
Fun Finder 2012 X189FBS sold
2020 Lance model 2075
2016 Ram 1500 EcoDiesel 4x4
jbfunfinder is offline   Reply With Quote
Old 09-25-2015, 08:23 PM   #6
Junior Member
 
Join Date: Sep 2015
Posts: 1
Default

I have the same problem in my 2011 189 x fbr . The problem is pulling up the middle connection for water flow. It flows to the sink but no longer works going to the shower. Sometimes it works for a few seconds but the middle pull up valve seems to be getting out of alignment and blocking flow. I having figured out how to take this apart yet.


2013 Ford F150
2011 Funfinder
Bamadeb
__________________

bamadeb is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:16 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×