Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 06-23-2015, 12:18 PM   #1
Junior Member
 
Join Date: Jun 2015
Location: Vermont
Posts: 18
Default Water heater not working

I have a 2011 SF x189. I have a gas/ele water heater.

When I put the on button of the water heat to on the red light for the reset comes on. Outside at the water heater the two buttons that say reset I push and the clicking stops. I believe the water was full when testing it the other day.
Also there is a switch on - off that is off with a wire not allowing it to be switch to on. Is that making any sense?

So how do I test? is there a heating element that needs replacing?

Its like buy the camper and learn what and what not to do this way you become a expert! Depending on the gray cells that are left from the 60's n70's

any how thanks for the helpers and the jokers
__________________

greenmtnman is offline   Reply With Quote
Old 06-23-2015, 02:07 PM   #2
Senior Member
 
Join Date: Jan 2012
Location: South Dakota
Posts: 3,106
Default

Here is an owners manual for gas/electric water heater.

The last several pages detail operation.

http://bryantrv.com/docs2/docs/operating/swinstall.pdf

Not sure if you have the same water heater ... if not you can google your model and the owners manual will probably be on line.
__________________

__________________
2012 Fun Finder XT 276 Toy Hauler & Harley Davidson Ultra Classic with Condor wheel chock
2014 Dodge Ram 2500 AT 4X4 Crew Cab 6.4 L Hemi, 373 gears, tow package, Rambox option, Revolver X2 tonneau cover, Equal-I-zer anti-sway hitch.
Eagle is offline   Reply With Quote
Old 06-25-2015, 09:35 PM   #3
Senior Member
 
Join Date: Apr 2012
Location: TN
Posts: 414
Default Water Heater

The clicking you hear sounds like the ignitor is trying to light the pilot light. Make sure your propane tanks are full - make sure the propane has time to make it to the back of the camper to the water heater.
The button with the wire through it is the electric power button. They put a wire (cotter pin) through it to make sure you have put water in the tank before switching it on to electric mode. It will heat when connected to shore (electric) power.

There are two thermostats, one for the electric mode and one for the propane mode. I've had to replace one when it failed.

Hope this information helps.
__________________
2012 FunFinder X 210UDS
4-68 watt flexible panels; 1-215 glass panel/4 Battle Born LiFePO4 Deep Cycle Batteries
2014 Ford F350 6.7 Liter PowerStroke V-8 Diesel longbed, SRW
runner421 is offline   Reply With Quote
Old 06-26-2015, 02:13 PM   #4
Junior Member
 
Join Date: Jun 2015
Location: Vermont
Posts: 18
Default

Thanks for all replies they have been helpful.
Propane side works and hot water we will have.
I also check out the heating element and its ok.
Next I'm planning on checking the thermostats. I'm sure that's were the problem lies. Well I'm hoping that's all that it could be and that its the only thing that's next. Since no one else has added a different problem that it could be.

Thanks again to all have a good weekend
greenmtnman is offline   Reply With Quote
Old 07-02-2015, 10:05 AM   #5
Senior Member
 
Join Date: Apr 2012
Location: TN
Posts: 414
Default More info

So - there are two thermostats. You can troubleshoot by switching the thermostats. They are contact thermostats - make contact with the outside of the water heater - not inside like residential water heaters.
What worked for me was simply swapping the wiring connections from one to the other thermostat. They're right next to each other.
If the propane thermostat is good - you should get ignition when you use the switch in the camper. If you can get the propane to work on both thermostats, they're both probably good. It's the fastest way to check without a meter or waiting for the electric mode to heat up.
I just had the electric switch go bad. It was sticky and when in the on position, no electric hot water. Removed the switch, tested and it's bad. Off to buy a new one.
__________________
2012 FunFinder X 210UDS
4-68 watt flexible panels; 1-215 glass panel/4 Battle Born LiFePO4 Deep Cycle Batteries
2014 Ford F350 6.7 Liter PowerStroke V-8 Diesel longbed, SRW
runner421 is offline   Reply With Quote
Old 07-05-2015, 09:16 PM   #6
Senior Member
 
Join Date: Jan 2012
Location: South Dakota
Posts: 3,106
Default

Some more information if interested:

http://www.rvrepairclub.com/video/al...heater-007925/


http://www.rvrepairclub.com/video/rv...g-tips-007928/
__________________

__________________
2012 Fun Finder XT 276 Toy Hauler & Harley Davidson Ultra Classic with Condor wheel chock
2014 Dodge Ram 2500 AT 4X4 Crew Cab 6.4 L Hemi, 373 gears, tow package, Rambox option, Revolver X2 tonneau cover, Equal-I-zer anti-sway hitch.
Eagle is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 05:27 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×