Free 7 Day Trial RV GPS App RV Trip Planner Campground Reviews RV Maintenance Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-26-2021, 01:05 PM   #1
Junior Member
 
Join Date: Mar 2017
Posts: 21
Default Water heater not working.

Trying to get the trailer ready for its first trip, making sure everything is working. Everything is working, except the water heater. Its a gas/electric unit, but isn't functioning on either. The gas appliances are working the electric ones are to.
Trailer has been plugged in to shore power since bringing it home, but I've had the unit switched off at the switch inside the WH service panel on the outside, and it was drained during the winter. Not sure what to check to try and get it going before Sunday. 1st pic is the WH switch on LP gas, 2nd is when I try and run off power, 3d is inside the service panel showing the switch that I turned off after draining it for the winter. Lots of oxidation on all the galvanized items, neither the dealer or I live near the coast, asked the dealer about this, they said thats from where it was manufactured???
Attached Thumbnails
IMG_20210326_112925977.jpg   IMG_20210326_112932346.jpg   IMG_20210326_113726733_HDR.jpg  
__________________

Steve079 is offline   Reply With Quote
Old 03-26-2021, 03:54 PM   #2
Junior Member
 
Join Date: Mar 2017
Posts: 21
Default

Well Google to the rescue. Turns out that when I flip the switch that lights up the DSI fault light, it stays on until the water heater lights. I switched it on and the it lit with in 30 seconds.
Looks like all systems are operational.
__________________

Steve079 is offline   Reply With Quote
Old 03-26-2021, 05:42 PM   #3
Senior Member
 
Join Date: Feb 2012
Location: Southern California
Posts: 1,877
Default

Great news! Where are you going on your first trip?
__________________
2012 Fun Finder X-139 "Boondock Style" (axle-flipped and extra insulation)
2013 Toyota Tacoma Off-Road (semi-beefy tires and components)
profdant139 is offline   Reply With Quote
Old 03-26-2021, 06:43 PM   #4
Junior Member
 
Join Date: Mar 2017
Posts: 21
Default

San Simeon State Park. Swing by, lol.
Steve079 is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 12:07 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
×