Reply
 
Thread Tools Search this Thread Display Modes
 
Old 03-28-2018, 02:16 PM   #1
Senior Member
 
Join Date: Jan 2016
Posts: 1,330
Default LEDs interfering with radio/tv?

This is a new issue to us since we never watch tv in our camper. Do your LED lights cause your tv and/or radio to act strange? There is a lot of talk about this on Google but I never saw it on any of the RV forums until today.
__________________

__________________
2008 Fun Finder 189 FBR, (replaced by) 1996 Shasta 265DBFW April 2017.
2006 Jeep Liberty 3.7 (replaced by.....)
2006 Chevy 2500HD, Duramax, crew cab
It's a big world...explore it!!!
Michigantraveler is offline   Reply With Quote
Old 03-28-2018, 02:38 PM   #2
Member
 
SWFL FlyFisher's Avatar
 
Join Date: Jan 2018
Location: Placida, FL
Posts: 71
Default

We don't have LEDs in our trailer, but we do in our sailboat and have seen interference with TV reception from time to time but not consistently. In the trailer we have found that the vent fan in the bedroom affects some TV channels.
__________________

__________________
Daz

2012 FunFinder X-214WSD
2005 F150 FX4
SWFL FlyFisher is offline   Reply With Quote
Old 03-28-2018, 04:04 PM   #3
Senior Member
 
Silverado's Avatar
 
Join Date: Apr 2017
Location: Fort Saskatchewan Alberta
Posts: 209
Default

My 2015 210uds has no issues with interference, I replaced all interior lights with LED lights. Radio appears to work fine but have never been able to get one TV channel to work since we have owned it. Silverado
__________________
2015 FunFinder 210uds, 2014 Silverado LTZ-Z71 Regular Cab Short Box, 5.3l with towing package
Silverado is offline   Reply With Quote
Old 03-28-2018, 04:30 PM   #4
Member
 
SWFL FlyFisher's Avatar
 
Join Date: Jan 2018
Location: Placida, FL
Posts: 71
Default

Quote:
Originally Posted by Silverado View Post
Radio appears to work fine but have never been able to get one TV channel to work since we have owned it. Silverado
Not to hijack the thread, but we had the same issue. I can never get anything OTA using the OEM roof mount antenna so I fixed it by making my own extendable 25' tall external antenna using a regular household RCA antenna and an extendable flagpole with a hitch mount. We now get more channels in the FunFinder than we do in the house (where we have the same antenna mounted in the attic). The flagpole stores under the rear bumper in a custom made tube and mounts in a receiver on the rear bumper. The antenna raises about 25' above ground. I have an ap on my phone that tells me which direction to point the antenna for best reception wherever we are. I drilled and tapped the mount for a thumb set screw so once the antenna gets pointed it stays. I run a section of coax from the antenna to the cable inlet on the port side and switch the antenna amp to "cable" - Works like a dream. I've got a few pics if you're interested in seeing the whole thing in action.
__________________
Daz

2012 FunFinder X-214WSD
2005 F150 FX4
SWFL FlyFisher is offline   Reply With Quote
Old 03-28-2018, 05:26 PM   #5
Senior Member
 
Silverado's Avatar
 
Join Date: Apr 2017
Location: Fort Saskatchewan Alberta
Posts: 209
Default

Quote:
Originally Posted by SWFL FlyFisher View Post
Not to hijack the thread, but we had the same issue. I can never get anything OTA using the OEM roof mount antenna so I fixed it by making my own extendable 25' tall external antenna using a regular household RCA antenna and an extendable flagpole with a hitch mount. We now get more channels in the FunFinder than we do in the house (where we have the same antenna mounted in the attic). The flagpole stores under the rear bumper in a custom made tube and mounts in a receiver on the rear bumper. The antenna raises about 25' above ground. I have an ap on my phone that tells me which direction to point the antenna for best reception wherever we are. I drilled and tapped the mount for a thumb set screw so once the antenna gets pointed it stays. I run a section of coax from the antenna to the cable inlet on the port side and switch the antenna amp to "cable" - Works like a dream. I've got a few pics if you're interested in seeing the whole thing in action.
Yes that would be nice. Thanks in advance. I just assumed there was no "FREE" TV anymore. I am in Canada if that makes any difference. I could not pick any up when I was in Idaho last summer either.
__________________
2015 FunFinder 210uds, 2014 Silverado LTZ-Z71 Regular Cab Short Box, 5.3l with towing package
Silverado is offline   Reply With Quote
Old 03-29-2018, 05:40 AM   #6
Senior Member
 
Join Date: Jan 2016
Posts: 1,330
Default

Here is one of the sites that talks about the issue.

Led lights interfere with TV reception - General RV Information - Escapees Discussion Forum
__________________
2008 Fun Finder 189 FBR, (replaced by) 1996 Shasta 265DBFW April 2017.
2006 Jeep Liberty 3.7 (replaced by.....)
2006 Chevy 2500HD, Duramax, crew cab
It's a big world...explore it!!!
Michigantraveler is offline   Reply With Quote
Old 03-29-2018, 05:50 AM   #7
Senior Member
 
Join Date: Jan 2016
Posts: 1,330
Default

Iím wondering if the problem was only with older versions of LED bulbs since I donít find any later threads with issues with them. Or possibly just some of those manufactured.
Michigantraveler is offline   Reply With Quote
Old 08-12-2018, 05:34 PM   #8
Junior Member
 
Join Date: Jun 2017
Location: Painted Post, NY
Posts: 12
Default

Quote:
Originally Posted by Michigantraveler View Post
This is a new issue to us since we never watch tv in our camper. Do your LED lights cause your tv and/or radio to act strange? There is a lot of talk about this on Google but I never saw it on any of the RV forums until today.
Is the antenna booster turned ON? I can't get any TV channels without it.
__________________

jimplumley is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 03:31 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
×