FunfinderClub

FunfinderClub (https://www.funfinderclub.com/forums/)
-   Fun Finder Community (https://www.funfinderclub.com/forums/f8/)
-   -   2 weeks on the road with our new to us X160 (https://www.funfinderclub.com/forums/f8/2-weeks-on-the-road-with-our-new-to-us-x160-2108.html)

chily3 07-22-2014 12:30 PM

2 weeks on the road with our new to us X160
 
We had a very good trip from Sacramento to Mt Hood area then west to the coast and back home via Oregon and Calif. west coast. Used State Parks and a few RV parks. All went well and even averaged 12 MPG for the 2,200 mile trip. Only one minor thing went wrong, one of those JUNK china made water pressure regulators quit working and stopped the water flow. But as we went around Mt. Hood and came back to the river we were within a couple of exits from camping world and bought a new one.

Now working our next trip. :)

NEFANMAN 07-22-2014 09:04 PM

X160
 
We have had for almost a month and everything seems to work well. Taking this week for our longest journey to Maine coast. Only thing I've struggled with to get working is the outside shower. Bought a new hose with right connected but it doesn't seem to work.

chily3 07-22-2014 09:52 PM

I saw on another post, check the shower head for blockage. We have not used ours but the valve does work when the pump is on. Have not tried it with park water hose attached.

mike


All times are GMT -6. The time now is 02:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2021, vBulletin Solutions, Inc.