Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 04-30-2014, 05:42 AM   #1
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default New Fun Finder XT 276 issues

Good morning All,

Been going through my new XT 276 and finding the usual missing screws, poorly routed wires and miscellaneous missed quality control issues found on about every new camper. So far I really like the unit. Adding LEDs and all the little stuff to make it mine.

Two things have me concerned so far. The roof has some spots where there seems to be no adhesive and is not sticking. No tears but just not attached to plywood or whatever is under covering. Will bring it back to the dealer after I go through everything else.

The speaker in the garage is not working. I pulled the speaker, which is ok but there is a break in the wire somewhere between stereo and speaker. And of course the wire is not loose so I cannot attach a new wire and pull. I don't see a way to pull a new wire without pulling the ceiling which I don't want.

Overall the camper looks pretty good so far.

Mark
__________________

__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 04-30-2014, 06:56 AM   #2
Member
 
Join Date: Feb 2014
Posts: 66
Default

Mark
Pull the radio out of the cabinet and check there if you have not done so yet. I had the big suprise back there and the wireing problem is hopfully there. Also pull the plate off the bottom of the showere base if you have one and let us know how big and the shape of the hole cut in the floor. I had to fill ours with a foam sheet to keep the cold out. Please let me know which LED lamp you installed and if you purchased them on line.
Thanks
Don
__________________

__________________
Fun finder extra XT-330
BMW R1200RT
BMW R1100RT
GMC Denali-retired
2014 Chevy 2500HD crew cab 4x4
dberg is offline   Reply With Quote
Old 04-30-2014, 08:21 AM   #3
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

Hi Don,

Already pulled the radio in the hope that a wire was loose. No such luck. I tied the wires on one end together and checked continuity and confirmed the wire is bad. What a rats nest back there. Not sure how bad it will be to run a wire.

These are the LED bulbs I ordered on Amazon for the overhead fixtures

http://www.amazon.com/gp/product/B00...?ie=UTF8&psc=1

They seem to work well. I am still looking for the right bulbs for the smaller fixtures.

I haven't opened each hatch yet but thanks for the heads up.

Mark
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 04-30-2014, 09:00 AM   #4
Member
 
Join Date: Apr 2014
Location: Minden, NV
Posts: 34
Default

http://www.amazon.com/gp/product/B00...?ie=UTF8&psc=1

I used these LEDS. Replaced every bulb in unit. They have almost the same look as the 921
jtwcummins is offline   Reply With Quote
Old 04-30-2014, 04:53 PM   #5
Junior Member
 
Join Date: Nov 2013
Location: eastern PA.
Posts: 4
Default

if you remove the ceiling light in the center of the bathroom you should see two wire raceways, one should have the speaker wire, the other 12volt power and lights, maybe you can see if you can get the speaker wire to move at this point. My friends 276 was this way with wires branching off through the foam to the vent fan motor. Maybe the speaker wire in yours was run similar back in the garage.
webslinger is offline   Reply With Quote
Old 04-30-2014, 05:48 PM   #6
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

Thanks Webslinger, I'll take a look tomorrow.
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 05-01-2014, 09:47 AM   #7
roy
Senior Member
 
Join Date: Feb 2012
Location: Mississippi
Posts: 303
Default

Join the club of 276 misfires. I have been dealing with it since Dec 2011. It's an on going job with this thing every trip every movement requires a repair or redesign by me.

Btw my roof is the same in spots especially near the front corners and along the edges. It's got no worse since new. Do keep an eye on the front corner areas that join front cap they like to puddle water in those spots eventually breaking down the sealant used there. Leak will spring up as the sealant cracks. Dap self leveling compound is your friend up there. Buy a tube and keep it on ready.
__________________
2012 Fun finder Xtra XT-276, Pitbull strapless restraints
2016 GMC Sierra Denali HD Duramax/Allison 4wd

WERA Expert #826
roy is offline   Reply With Quote
Old 05-01-2014, 02:09 PM   #8
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

Speaker 1 : Mark 0

Pulled the bathroom vent and found the wire path. Also found speaker wire with wire pulled out of connector. Got excited and repaired it, turned on stereo and still no sound in garage. Agggggggg!!!!!!!!!!

Tested wires from vent area to stereo and no continuity. Tied a new wire to pull through and existing wire broke in wall before I could pull new wire through. Game over. It became personal! And I lost.

Oh well, on to next project.
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 05-01-2014, 02:13 PM   #9
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

Thanks Roy. I'll get a tube of Dap to keep on hand.
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 05-01-2014, 08:26 PM   #10
Senior Member
 
Join Date: May 2012
Location: chandler, az
Posts: 197
Send a message via AIM to shadow
Default

should be able to use a wire puller, distance isn't that far. first make sure the output from the stereo is working!
__________________
Shadow
189FDS
2012 Tundra 5.87 4x4
shadow is offline   Reply With Quote
Old 05-01-2014, 08:39 PM   #11
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

Tried a wire puller. Too many turns. I tied a string to old wire but as I was pulling it got stuck on something and the wire broke.

I did connect a new wire and confirmed the output is good.

I am taking it back to dealer for,some warranty work later this month. I am hoping it will be covered under warranty since it didn't work when I got it. I want it fixed but if this one speaker not working is my worst problem on this camper I guess I can't complain too much.
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 05-02-2014, 04:09 AM   #12
Senior Member
 
Join Date: Jan 2012
Location: South Dakota
Posts: 3,106
Default

Checking the entire unit over, including speaker function SHOULD have been on the pre delivery check list by your dealer, found by your dealer and corrected.

In two years, I've had only minor tweeking needed here and there.

I'm a happy camper.
__________________
2012 Fun Finder XT 276 Toy Hauler & Harley Davidson Ultra Classic with Condor wheel chock
2014 Dodge Ram 2500 AT 4X4 Crew Cab 6.4 L Hemi, 373 gears, tow package, Rambox option, Revolver X2 tonneau cover, Equal-I-zer anti-sway hitch.
Eagle is offline   Reply With Quote
Old 05-04-2014, 07:53 PM   #13
Junior Member
 
Join Date: Nov 2013
Location: United States
Posts: 6
Send a message via AIM to kmartin410
Default Our new 2015 276

We took delivery of our new 276 this weekend and the rear speaker did not work. Our dealer sent a repairman to the campground and found the radio output to be the issue. Need new radio.

Will get one tomorrow, if in stock, or have it delivered to our home.

Hope this helps.

Kathy and Steve
__________________
Kathy and Steve
Maryland

2014 276 Xtra - totaled by tree fall 3/14
2015 276 Xtra - delivered 5/14
kmartin410 is offline   Reply With Quote
Old 05-15-2014, 05:29 AM   #14
Member
 
Join Date: Apr 2014
Location: Florida
Posts: 78
Default

I have spent the past couple of weeks going through my camper to find all the little things that needed "attention". Many of my water connections were loose and needed tightening and other little things at could have gotten bigger if they had not been caught, as well as personalization of adding all the comfort and convenience items. Overall I am happy camper with my camper.
__________________
Mark S
2014 Fun Finder 276
2015 Ford F150 Ecoboost 4x4
2011Harley Road Glide Ultra
Mark S is offline   Reply With Quote
Old 05-15-2014, 06:35 AM   #15
Senior Member
 
Join Date: Jan 2012
Location: South Dakota
Posts: 3,106
Default

Good deal Mark.

And the nice thing about going thru your new unit is you learn (aka gain some inside knowledge) about how/why things work and that allows you to better understand your camper, it's capabilities and it's limitations.

Everything has capabilities and limitations.

Happy camping.
__________________

__________________
2012 Fun Finder XT 276 Toy Hauler & Harley Davidson Ultra Classic with Condor wheel chock
2014 Dodge Ram 2500 AT 4X4 Crew Cab 6.4 L Hemi, 373 gears, tow package, Rambox option, Revolver X2 tonneau cover, Equal-I-zer anti-sway hitch.
Eagle is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 01:31 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×