Journey with Confidence RV GPS App RV Trip Planner RV LIFE Campground Reviews RV Maintenance Take a Speed Test Free 7 Day Trial ×
 



Reply
 
Thread Tools Search this Thread Display Modes
 
Old 11-02-2014, 03:11 PM   #1
Junior Member
 
Join Date: Sep 2014
Posts: 19
Default Winterizing ??

Hi everyone I am an avid reader of this group and now we are having a problem.. We are trying to winterize our ntu 2013 X FBS.. We blew out the lines and now we are trying to pump antifreeze thru the lines. It will not suck it up.. Hubby has tried everything he can think of, and I have searched here and other forums for hints.. Not new to TT maintenence, but never ran into this oroblem before..
Hope someone has an idea cause it is getting mighty cold here in MI.

Thanks in advance and Camp Happy
__________________

__________________
CAMP HAPPY!
slbahle is offline   Reply With Quote
Old 11-02-2014, 09:11 PM   #2
Senior Member
 
Join Date: Sep 2014
Location: North Georgia
Posts: 466
Default

When you say "it will not suck it up" ... you need to be a bit clearer what you mean. If you're just putting anti-freeze in the fresh water tank and running the pump like normal, then you need to put in more anti-freeze depending in where the pick up tube is in the fresh water tank.

If that's not how you're doing it but rather by a separate tube connected directly to the water pump, you need to switch the diverter valve in line with that hose as opposed to the line that normally feeds the rest of the trailer's water lines.



__________________

__________________
Ex Owners of a 2015 Fun Finder 214 WSD
2016 Ram 2500HD with 6.4L Hemi
Travels with Yoly is offline   Reply With Quote
Old 11-03-2014, 01:47 AM   #3
Junior Member
 
Join Date: Sep 2014
Posts: 19
Default winterizing??

Hi.. First thank you for answering us.. We are trying to get it to pick it up from the bottle of anti freeze.. Tube in bottle, is it possible the pump lost it's prime and needs to be primed? We will re-check all our valves and hopefully this will be the charm
__________________
CAMP HAPPY!
slbahle is offline   Reply With Quote
Old 11-03-2014, 06:28 AM   #4
roy
Senior Member
 
Join Date: Feb 2012
Location: Mississippi
Posts: 303
Default

I tried a different method this year. Grew tired of the anti freeze method and switched over to the compressed air method. So far I like this better. It took a little longer to do but not as messy and no lingering smell or taste in tye water system. It has already been 27 degrees here and so far all is well.

My pump has its own feed like for winterizing with anti freeze. I found the pump to be hard at times to pick up a prime but opening the nearest faucet usually does the trick. When I would switch to water on de winterizing I would always use my city water port with a hose and fill hot wafer tank the pressurize the entire system first. After that the pump always primes up quickly when pulling from water in the holding tank.
__________________
2012 Fun finder Xtra XT-276, Pitbull strapless restraints
2016 GMC Sierra Denali HD Duramax/Allison 4wd

WERA Expert #826
roy is offline   Reply With Quote
Old 11-03-2014, 09:02 AM   #5
Junior Member
 
Join Date: Sep 2014
Posts: 19
Default winterizing??

Thanks for the hints.. We are trying evverything.. Hubs is on the phone right now with our dealer.. I will post here what we find out..
__________________
CAMP HAPPY!
slbahle is offline   Reply With Quote
Old 11-03-2014, 10:00 PM   #6
Junior Member
 
Join Date: Sep 2014
Posts: 19
Default Winterizing??

Well, are you ready for this one.. The service dept at our dealer installed the valve upside down..Oh my! Soon as we fixed that the pump syphoned fine and we are all winterized..
Thanks for the help!
__________________
CAMP HAPPY!
slbahle is offline   Reply With Quote
Old 11-03-2014, 10:23 PM   #7
Senior Member
 
Join Date: Sep 2014
Location: North Georgia
Posts: 466
Default

That makes sense .... and glad you got that figured out. I'm pretty new to this process as well and wouldn't have thought of that so we both learned something here. Thanks for updating



__________________
Ex Owners of a 2015 Fun Finder 214 WSD
2016 Ram 2500HD with 6.4L Hemi
Travels with Yoly is offline   Reply With Quote
Old 11-04-2014, 05:33 AM   #8
Junior Member
 
Join Date: Sep 2014
Posts: 19
Default

Glad to Help..
__________________

__________________
CAMP HAPPY!
slbahle is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

» Featured Campgrounds

Reviews provided by

Powered by vBadvanced CMPS v3.2.3
Disclaimer:

This website is not affiliated with or endorsed by Fun Finder RV, Cruiser RV, or any of its affiliates. This is an independent, unofficial site.


All times are GMT -6. The time now is 09:35 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2024, vBulletin Solutions, Inc.
×